Pour les thèmes :

La version 2.1.6 de Dotclear arrive bientôt. L'implication sur les thèmes "simples" est minime :

-Pour les thèmes n'utilisant que des CSS, il n'y a rien à faire.

-Pour les thèmes contenant leur propres templates : Le template 404.html contenait jusqu'à présent tpl:lang The document you are looking for does not exists., ça doit maintenant être remplacé par tpl:lang The document you are looking for does not exist. (notez le "s" qui a été supprimé à la fin.) Si vous ne faites pas le changement, la ligne ne sera pas traduite.

Les balises de template des tags ont été renommées et doivent être remplacées dans les fichiers .html comme suit :

MetaData: Tags MetaDataHeader: TagsHeader MetaDataFooter: TagsFooter MetaID: TagID MetaPercent: TagPercent MetaRoundPercent: TagRoundPercent MetaURL: TagURL MetaAllURL: TagCloudURL EntryMetaData: EntryTags

Si votre thème contient des instruction PHP ou du javascript, consultez le post sur les mises à jour des plugins.

Voir le billet sur le forum

Pour les plugins:

L'appel à p404() ne termine plus le traitement. Si vous utilisez cette fonction, la modification est simple : après chaque appel à p404(), ajoutez un return;. Si ça vous concerne, il y a de fortes chances que votre plugin définisse des URL Handlers, si c'est le cas, le exit est maintenant proscrit et doit simplement être remplacé par return.

JQuery a été mis à jour en version 1.3. Ca signifie que les selecteurs de type @tag, obsolètes depuis la 1.2 (donc qui ne devraient plus être utilisés depuis la 1.1) ne fonctionnent plus. La modification est également très simple à réaliser : cherchez "[@" dans vos instructions javascript et supprimez l'arobase.

Voir le billet sur le forum